<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://wallstreetpit.com/xmlrpc.php" />
<title>Tesla Stock Surging Back to Near-Record Highs - Wall Street Pit</title>
<meta name="dc.title" content="Tesla Stock Surging Back to Near-Record Highs - Wall Street Pit" />
<meta name="dc.description" content="Shares of Tesla (NASDAQ:TSLA) jumped more than 73 points higher in morning trading on Wednesday, after Piper Sandler&#039;s Alexander Potter increased his price target for the automaker’s stock by almost $200 - to $928 a share from $729. As of 10:27 p.m. EST, the stock was up about 8.5% to&hellip;" />
<meta name="dc.relation" content="https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/" />
<meta name="dc.source" content="https://wallstreetpit.com/" />
<meta name="dc.language" content="en_US" />
<meta name="description" content="Shares of Tesla (NASDAQ:TSLA) jumped more than 73 points higher in morning trading on Wednesday, after Piper Sandler&#039;s Alexander Potter increased his price target for the automaker’s stock by almost $200 - to $928 a share from $729. As of 10:27 p.m. EST, the stock was up about 8.5% to&hellip;" />
<meta name="thumbnail" content="https://wallstreetpit.com/wp-content/uploads/2017/06/tesla-logo3-150x100.jpg" />
<meta name="robots" content="noodp, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/" />
<meta name="author" content="WSP">
<meta property="og:url" content="https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/" />
<meta property="og:site_name" content="Wall Street Pit" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="article:author" content="https://www.facebook.com/wallstreetpit" />
<meta property="article:publisher" content="https://www.facebook.com/wallstreetpit" />
<meta property="article:section" content="News" />
<meta property="article:tag" content="TSLA" />
<meta property="og:title" content="Tesla Stock Surging Back to Near-Record Highs - Wall Street Pit" />
<meta property="og:description" content="Shares of Tesla (NASDAQ:TSLA) jumped more than 73 points higher in morning trading on Wednesday, after Piper Sandler&#039;s Alexander Potter increased his price target for the automaker’s stock by almost $200 - to $928 a share from $729. As of 10:27 p.m. EST, the stock was up about 8.5% to&hellip;" />
<meta property="og:image" content="https://wallstreetpit.com/wp-content/uploads/2017/06/tesla-logo3.jpg" />
<meta property="og:image:secure_url" content="https://wallstreetpit.com/wp-content/uploads/2017/06/tesla-logo3.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="427" />
<meta property="og:image:alt" content="tesla logo" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@wallstreetpit" />
<meta name="twitter:creator" content="@wallstreetpit" />
<meta name="twitter:title" content="Tesla Stock Surging Back to Near-Record Highs - Wall Street Pit" />
<meta name="twitter:description" content="Shares of Tesla (NASDAQ:TSLA) jumped more than 73 points higher in morning trading on Wednesday, after Piper Sandler&#039;s Alexander Potter increased his price target for the automaker’s stock by almost $200 - to $928 a share from $729. As of 10:27 p.m. EST, the stock was up about 8.5% to&hellip;" />
<meta name="twitter:image" content="https://wallstreetpit.com/wp-content/uploads/2017/06/tesla-logo3.jpg" />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Wall Street Pit &raquo; Feed" href="https://wallstreetpit.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wall Street Pit &raquo; Comments Feed" href="https://wallstreetpit.com/comments/feed/" />
<script type="application/ld+json">{
						"@context": "https://schema.org","@type": "NewsArticle","mainEntityOfPage": {
								"@type": "WebPage",
								"@id": "https:\/\/wallstreetpit.com\/115461-tesla-tsla-stock-record-highs"
							},"headline": "Tesla Stock Surging Back to Near-Record Highs","image": {
								"@type": "ImageObject",
								"url": "https:\/\/wallstreetpit.com\/wp-content\/uploads\/2017\/06\/tesla-logo3.jpg"
							},"datePublished": "2020-02-19T11:12:57-05:00",
						"dateModified": "2020-02-19T12:56:11-05:00",
						"author": {
							"@type": "Person",
							"name": "WSP"
						},"description": "&lt;a class=&quot;mh-excerpt-more&quot; href=&quot;https:\/\/wallstreetpit.com\/115461-tesla-tsla-stock-record-highs\/&quot; title=&quot;Tesla Stock Surging Back to Near-Record Highs&quot;&gt;&lt;\/a&gt;"}</script>
<script type="application/ld+json">{"@context" : "https://schema.org","@type" : "LocalBusiness","@id": "https:\/\/wallstreetpit.com","priceRange": "editor","openingHoursSpecification": [{ "@type": "OpeningHoursSpecification","dayOfWeek": "Monday", "opens": "00:00","closes": "00:00"}, { "@type": "OpeningHoursSpecification","dayOfWeek": "Tuesday", "opens": "00:00","closes": "00:00"}, { "@type": "OpeningHoursSpecification","dayOfWeek": "Wednesday", "opens": "00:00","closes": "00:00"}, { "@type": "OpeningHoursSpecification","dayOfWeek": "Thursday", "opens": "00:00","closes": "00:00"}, { "@type": "OpeningHoursSpecification","dayOfWeek": "Friday", "opens": "00:00","closes": "00:00"}, { "@type": "OpeningHoursSpecification","dayOfWeek": "Saturday", "opens": "00:00","closes": "00:00"}, { "@type": "OpeningHoursSpecification","dayOfWeek": "Sunday", "opens": "00:00","closes": "00:00"} ],"name": "Wall Street Pit"}</script>
<link rel="alternate" type="application/rss+xml" title="Wall Street Pit &raquo; Tesla Stock Surging Back to Near-Record Highs Comments Feed" href="https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wallstreetpit.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://wallstreetpit.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://wallstreetpit.com/wp-content/themes/mh-magazine/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-child-css'  href='https://wallstreetpit.com/wp-content/themes/mh-magazine-child/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://wallstreetpit.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Raleway:300,400,400italic,600,700%7cCantarell:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://wallstreetpit.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://wallstreetpit.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://wallstreetpit.com/wp-content/themes/mh-magazine/js/scripts.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://wallstreetpit.com/wp-json/' />
<link rel='prev' title='Apple Stock Sharply Lower As Virus Fears Hit Global Suppliers' href='https://wallstreetpit.com/115457-apple-stock-sharply-lower/' />
<link rel="alternate" type="application/json+oembed" href="https://wallstreetpit.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwallstreetpit.com%2F115461-tesla-tsla-stock-record-highs%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wallstreetpit.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwallstreetpit.com%2F115461-tesla-tsla-stock-record-highs%2F&#038;format=xml" />
<link rel='amphtml' href='https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/amp/' /><style type="text/css">
.mh-header-nav li:hover, .mh-header-nav ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-main-nav ul li:hover > ul, .mh-extra-nav li:hover, .mh-extra-nav ul li:hover > ul, .mh-footer-nav li:hover, .mh-footer-nav ul li:hover > ul, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #respond #cancel-comment-reply-link:hover, #infinite-handle span:hover { background: #000000; }
.mh-extra-nav-bg { background: rgba(0, 0, 0, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #000000; background: rgba(0, 0, 0, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(0, 0, 0, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #000000; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #013450; background: rgba(1, 52, 80, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #respond #cancel-comment-reply-link, #infinite-handle span { background: #013450; }
blockquote, .mh-category-desc, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, .bypostauthor .mh-comment-meta, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #013450; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more { color: #013450; }
.mh-header-nav-bottom li a, .mh-social-nav-bottom .fa-mh-social, .mh-boxed-layout .mh-ticker-item-bottom a, .mh-header-date-bottom, .page .entry-title, .page-title, .mh-section-title, .mh-category-desc, .mh-author-box, .mh-author-box a, .mh-post-nav a, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout3 .mh-widget-title a, .mh-tabbed-widget, .mh-tabbed-widget a, .mh-posts-horizontal-title a, .wpcf7-form, #respond, #respond a, #respond .comment-reply-title, .mh-comment-list, pre, code, blockquote, blockquote cite { color: #013450; }
.entry-content a, .mh-comment-content a { color: #1389eb; }
a:hover, .entry-content a:hover, .mh-author-box a:hover, .mh-post-nav a:hover, .mh-comment-content a:hover, #respond a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover { color: #005a8c; }
</style>
<!--[if lt IE 9]>
<script src="https://wallstreetpit.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 17px; font-size: 1.0625rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Cantarell", sans-serif; }
body { font-family: "Raleway", sans-serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="icon" href="https://wallstreetpit.com/wp-content/uploads/2018/08/cropped-icon-2-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://wallstreetpit.com/wp-content/uploads/2018/08/cropped-icon-2-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://wallstreetpit.com/wp-content/uploads/2018/08/cropped-icon-2-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://wallstreetpit.com/wp-content/uploads/2018/08/cropped-icon-2-270x270.jpg" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-115461 single-format-standard custom-background mh-wide-layout mh-right-sb mh-loop-layout1 mh-widget-layout3">
<div class="mh-header-mobile-nav clearfix"></div>

<header class="mh-header">

	<div class="mh-main-nav-wrap">

	<div class="mh-container mh-container-inner mh-row clearfix">
		<div class="mh-col-1-3 mh-custom-header">
<a href="https://wallstreetpit.com/" title="Wall Street Pit" rel="home">
<div class="mh-site-logo" role="banner">
<img class="mh-header-image" src="https://wallstreetpit.com/wp-content/uploads/2016/10/wsp_logo.jpg" height="50" width="220" alt="Wall Street Pit" />
</div>
</a>
</div>
        </div>

	<div class="mh-container mh-container-inner mh-row clearfix">
		<nav class="mh-main-nav mh-container mh-container-inner clearfix">
		<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-111035" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-111035"><a href="https://wallstreetpit.com/#">News</a>
<ul class="sub-menu">
	<li id="menu-item-111036" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-111036"><a href="https://wallstreetpit.com/articles/stocks/">Stocks</a></li>
	<li id="menu-item-104739" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-104739"><a href="https://wallstreetpit.com/articles/technology/">Technology</a></li>
	<li id="menu-item-112537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-112537"><a href="https://wallstreetpit.com/articles/science/">Science</a>
	<ul class="sub-menu">
		<li id="menu-item-112539" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112539"><a href="https://wallstreetpit.com/tag/science-tech/">Tech</a></li>
		<li id="menu-item-112538" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112538"><a href="https://wallstreetpit.com/tag/science-space/">Space</a></li>
		<li id="menu-item-112540" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112540"><a href="https://wallstreetpit.com/tag/science-human/">Human</a></li>
		<li id="menu-item-112541" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112541"><a href="https://wallstreetpit.com/tag/science-earth/">Earth</a></li>
	</ul>
</li>
	<li id="menu-item-111037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111037"><a href="https://wallstreetpit.com/articles/health/">Health</a></li>
	<li id="menu-item-104743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-104743"><a href="https://wallstreetpit.com/articles/politics/">Politics</a></li>
	<li id="menu-item-111038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111038"><a href="https://wallstreetpit.com/articles/world-news/">World</a></li>
	<li id="menu-item-110027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110027"><a href="https://wallstreetpit.com/articles/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-113164" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113164"><a href="https://wallstreetpit.com/tape/">TheTape</a></li>
<li id="menu-item-111040" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-111040"><a href="https://wallstreetpit.com/latest/">Latest</a></li>
<li id="menu-item-111042" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-111042"><a href="https://wallstreetpit.com/#">Follow WSP</a>
<ul class="sub-menu">
	<li id="menu-item-111043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111043"><a href="https://www.feedburner.com/fb/a/emailverifySubmit?feedId=1766270&#038;loc=en_US" class="external" rel="nofollow" target="_blank">Newsletter</a></li>
	<li id="menu-item-111044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111044"><a href="https://wallstreetpit.com/feed">RSS</a></li>
	<li id="menu-item-111045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111045"><a href="https://www.facebook.com/wallstreetpit" class="external" rel="nofollow" target="_blank">Facebook</a></li>
	<li id="menu-item-111046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111046"><a href="https://twitter.com/wallstreetpit" class="external" rel="nofollow" target="_blank">Twitter</a></li>
	<li id="menu-item-111047" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111047"><a href="https://plus.google.com/+Wallstreetpit" class="external" rel="nofollow" target="_blank">Google+</a></li>
</ul>
</li>
<li id="menu-item-114356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114356"><a href="https://wallstreetpit.com/authors/">Authors</a></li>
</ul></div>		</nav>

		<aside class="mh-header-search mh-header-search-bottom">
		<form role="search" method="get" class="search-form" action="https://wallstreetpit.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>	
		</aside>
        </div>

	
	</div>			

<!-- IC Random number generator START -->
<script language="javascript" type="text/javascript">var ord = Math.random() * 10000000000000000</script>
<!-- IC Random number generator END -->
		
</header>

<div class="mh-container mh-container-outer">
<div class="adblock-2">
<div id="text-13" class="mh-widget mh-header-2 widget_text">			<div class="textwidget"><div class="adblock-2">
<script src='//ads.investingchannel.com/adtags/wsp/indr_ads/728x90.js' type='text/javascript' charset='utf-8'></script> 
</div></div>
		</div></div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://wallstreetpit.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://wallstreetpit.com/articles/news/" itemprop="url"><span itemprop="title">News</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Tesla Stock Surging Back to Near-Record Highs</nav>
<article id="post-115461" class="post-115461 post type-post status-publish format-standard has-post-thumbnail category-news category-nokta category-stocks tag-tsla">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Tesla Stock Surging Back to Near-Record Highs		</h1>
		<p class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://wallstreetpit.com/date/2020/02/">February 19, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://wallstreetpit.com/author/editor/">WSP</a></span>
</p>
	</header>
		<div class="entry-content clearfix"><p style="text-align: center;"><img src="//wallstreetpit.com/wp-content/uploads/news/pbd/tesla-supercharger4.jpg" alt="Tesla Stock" border="0" /></p>
<p>Shares of <strong>Tesla</strong> (NASDAQ:<a href="http://wallstreetpit.com/tag/tsla/" target="_blank" rel="noopener noreferrer">TSLA</a>) jumped more than 73 points higher in morning trading on Wednesday, after Piper Sandler&#8217;s Alexander Potter increased his price target for the automaker’s stock by almost $200 &#8211; to $928 a share from $729.</p>
<p>As of 10:27 p.m. EST, the stock was up about 8.5% to $934.</p>
<p>In a note to investors, Potter, who rates TSLA the equivalent of &#8216;Buy&#8217;, said he expects the electric car-maker to achieve the same success in energy generation and storage that it has in vehicles.</p>
<p>Potter pointed to his own experience of recently installing a solar-based system to use for charging a Model X. The analyst <a href="https://www.thestreet.com/investing/tesla-new-record-price-target-boost" target="_blank" rel="noopener noreferrer nofollow" class="external">said</a> the &#8220;result have been illuminating so far.&#8221;</p>
<p>Tesla has a battery storage business and owns SolarCity—a company that specializes in solar energy services. Tesla also owns its network of electric vehicle charging stations. Tesla CEO Elon Musk has in fact been quoted as <a href="https://techcrunch.com/2019/10/23/elon-musk-predicts-tesla-energy-could-be-bigger-than-its-ev-business/" target="_blank" rel="noopener noreferrer nofollow" class="external">saying</a> that Tesla’s energy business could become bigger than its automotive sector.</p>
<p>This morning&#8217;s spike gives Tesla a market cap of about $170 billion. Its soaring stock price &#8211; the name is up more than 100% year-to- date and 204% year-over-year &#8211; has made it the second-most valuable car company in the world, behind Toyota, which is worth about $197 billion.</p>
<h2>Tesla Stock Price</h2>
<p>As of writing, Tesla&#8217;s stock is up 69 points to $928. The ticker, which has been in a general continuation of a steep ascent since early October, currently trades at 63x forward T12 EPS estimates. Tesla&#8217;s 52 week high: $969. 52 week low: $176.99.</p>

        <!-- AD Start -->
        <div class="adblock">
                <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
        <!-- Article_Bottom_Responsive -->
        <ins class="adsbygoogle"
        style="display:block"
        data-ad-client="ca-pub-9056915385448814"
        data-ad-slot="9275005321"
        data-ad-format="auto"
        data-full-width-responsive="true"></ins>
    <script>
        (adsbygoogle = window.adsbygoogle || []).push({});
    </script>
                </div>
        <!-- AD End -->

		<div class="mh-social-bottom">
<div class="mh-share-buttons mh-row clearfix">
	<a class="mh-col-1-4 mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/&t=Tesla Stock Surging Back to Near-Record Highs', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i></span>
	</a>
	<a class="mh-col-1-4 mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Tesla Stock Surging Back to Near-Record Highs -&url=https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i></span>
	</a>
	<a class="mh-col-1-4 mh-pinterest" href="#" onclick="window.open('https://www.reddit.com/submit?url=https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/&title=Tesla Stock Surging Back to Near-Record Highs', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
		<span class="mh-share-button"><i class="fa fa-reddit fa-2x"></i></span>
	</a>
	<a class="mh-col-1-4 mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i></span>
	</a>
</div></div>
	</div>

	<div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://wallstreetpit.com/tag/tsla/" rel="tag">TSLA</a></li></ul></div>	</article><nav class="mh-post-nav-wrap clearfix" role="navigation">
<div class="mh-post-nav-prev mh-post-nav">
<a href="https://wallstreetpit.com/115457-apple-stock-sharply-lower/" rel="prev">Previous article</a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-section-title mh-related-content-title">Related Articles</h3>
<div class="mh-related-wrap mh-row clearfix">
<article class="mh-col-1-3 mh-posts-grid-item clearfix post-109916 post type-post status-publish format-standard category-news category-stocks tag-hlf tag-tsla">
	<div class="mh-posts-grid-thumb">
		<a href="https://wallstreetpit.com/109916-notable-earnings-tesla-tsla-herbalife-ltd-hlf-cerner-corporation-cern/" title="Notable Earnings: Tesla (TSLA), Herbalife Ltd. (HLF), Cerner Corporation (CERN)"><img class="mh-image-placeholder" src="https://wallstreetpit.com/wp-content/themes/mh-magazine/images/placeholder-medium.png" alt="No Picture" />		</a>
		<div class="mh-image-caption mh-posts-grid-caption">
			News		</div>
	</div>
	<h3 class="mh-posts-grid-title">
		<a href="https://wallstreetpit.com/109916-notable-earnings-tesla-tsla-herbalife-ltd-hlf-cerner-corporation-cern/" title="Notable Earnings: Tesla (TSLA), Herbalife Ltd. (HLF), Cerner Corporation (CERN)" rel="bookmark">
			Notable Earnings: Tesla (TSLA), Herbalife Ltd. (HLF), Cerner Corporation (CERN)		</a>
	</h3>
	<div class="mh-meta mh-posts-grid-meta">
		<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>November 3, 2015</span>
<span class="mh-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://wallstreetpit.com/author/editor/">WSP</a></span>
	</div>
</article><article class="mh-col-1-3 mh-posts-grid-item clearfix post-113928 post type-post status-publish format-standard has-post-thumbnail category-news category-stocks tag-tsla">
	<div class="mh-posts-grid-thumb">
		<a href="https://wallstreetpit.com/113928-tesla-tsla-win-big-race/" title="Can Tesla (TSLA) Win the Big Race?"><img width="326" height="245" src="https://wallstreetpit.com/wp-content/uploads/2016/06/tesla-logo-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="tesla motors" srcset="https://wallstreetpit.com/wp-content/uploads/2016/06/tesla-logo-326x245.jpg 326w, https://wallstreetpit.com/wp-content/uploads/2016/06/tesla-logo-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
		<div class="mh-image-caption mh-posts-grid-caption">
			News		</div>
	</div>
	<h3 class="mh-posts-grid-title">
		<a href="https://wallstreetpit.com/113928-tesla-tsla-win-big-race/" title="Can Tesla (TSLA) Win the Big Race?" rel="bookmark">
			Can Tesla (TSLA) Win the Big Race?		</a>
	</h3>
	<div class="mh-meta mh-posts-grid-meta">
		<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>August 11, 2017</span>
<span class="mh-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://wallstreetpit.com/author/editor/">WSP</a></span>
	</div>
</article><article class="mh-col-1-3 mh-posts-grid-item clearfix post-100629 post type-post status-publish format-standard category-stocks tag-sune tag-trade-ideas tag-tsla tag-wbmd">
	<div class="mh-posts-grid-thumb">
		<a href="https://wallstreetpit.com/100629-trade-ideas-tsla-sune-wbmd/" title="Trade Ideas: TSLA, SUNE, WBMD"><img class="mh-image-placeholder" src="https://wallstreetpit.com/wp-content/themes/mh-magazine/images/placeholder-medium.png" alt="No Picture" />		</a>
		<div class="mh-image-caption mh-posts-grid-caption">
			Stocks		</div>
	</div>
	<h3 class="mh-posts-grid-title">
		<a href="https://wallstreetpit.com/100629-trade-ideas-tsla-sune-wbmd/" title="Trade Ideas: TSLA, SUNE, WBMD" rel="bookmark">
			Trade Ideas: TSLA, SUNE, WBMD		</a>
	</h3>
	<div class="mh-meta mh-posts-grid-meta">
		<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>July 15, 2013</span>
<span class="mh-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://wallstreetpit.com/author/editor/">WSP</a></span>
	</div>
</article></div>
</section>
<h4 id="mh-comments" class="mh-section-title mh-comment-form-title">Be the first to comment</h4>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/115461-tesla-tsla-stock-record-highs/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://wallstreetpit.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='115461' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ca39ad4d03" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="124"/></p></form>	</div><!-- #respond -->
			</div>
			<aside class="mh-widget-col-1 mh-sidebar">
		<div id="text-14" class="mh-widget widget_text">			<div class="textwidget"><script src='//ads.investingchannel.com/adtags/wsp/cryptocurrency/300x250.js' type='text/javascript' charset='utf-8'></script>
</div>
		</div><div id="mh_magazine_custom_posts-6" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">The Latest</span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
															<div class="mh-custom-posts-thumb">
									<a href="https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/" title="Tesla Stock Surging Back to Near-Record Highs"><img width="80" height="60" src="https://wallstreetpit.com/wp-content/uploads/2017/06/tesla-logo3-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="tesla logo" srcset="https://wallstreetpit.com/wp-content/uploads/2017/06/tesla-logo3-80x60.jpg 80w, https://wallstreetpit.com/wp-content/uploads/2017/06/tesla-logo3-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</div>
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/115461-tesla-tsla-stock-record-highs/" title="Tesla Stock Surging Back to Near-Record Highs">
										Tesla Stock Surging Back to Near-Record Highs									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>February 19, 2020</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
															<div class="mh-custom-posts-thumb">
									<a href="https://wallstreetpit.com/115457-apple-stock-sharply-lower/" title="Apple Stock Sharply Lower As Virus Fears Hit Global Suppliers"><img width="80" height="60" src="https://wallstreetpit.com/wp-content/uploads/2017/02/apple1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="apple" srcset="https://wallstreetpit.com/wp-content/uploads/2017/02/apple1-80x60.jpg 80w, https://wallstreetpit.com/wp-content/uploads/2017/02/apple1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</div>
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/115457-apple-stock-sharply-lower/" title="Apple Stock Sharply Lower As Virus Fears Hit Global Suppliers">
										Apple Stock Sharply Lower As Virus Fears Hit Global Suppliers									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>February 18, 2020</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
															<div class="mh-custom-posts-thumb">
									<a href="https://wallstreetpit.com/115446-nvidia-stock-soars-after-strong-earnings-beat/" title="Nvidia Stock Soars After Strong Earnings Beat"><img width="80" height="60" src="https://wallstreetpit.com/wp-content/uploads/2017/06/tech-nvidia-logo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="tech nvidia logo" srcset="https://wallstreetpit.com/wp-content/uploads/2017/06/tech-nvidia-logo-80x60.jpg 80w, https://wallstreetpit.com/wp-content/uploads/2017/06/tech-nvidia-logo-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</div>
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/115446-nvidia-stock-soars-after-strong-earnings-beat/" title="Nvidia Stock Soars After Strong Earnings Beat">
										Nvidia Stock Soars After Strong Earnings Beat									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>February 14, 2020</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
															<div class="mh-custom-posts-thumb">
									<a href="https://wallstreetpit.com/115444-twitter-stock-45-price-target/" title="Twitter Stock Gets $45 Price Target (TWTR)"><img width="80" height="60" src="https://wallstreetpit.com/wp-content/uploads/2016/06/twitter-wallst-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="twitter" srcset="https://wallstreetpit.com/wp-content/uploads/2016/06/twitter-wallst-80x60.jpg 80w, https://wallstreetpit.com/wp-content/uploads/2016/06/twitter-wallst-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</div>
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/115444-twitter-stock-45-price-target/" title="Twitter Stock Gets $45 Price Target (TWTR)">
										Twitter Stock Gets $45 Price Target (TWTR)									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>February 13, 2020</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
															<div class="mh-custom-posts-thumb">
									<a href="https://wallstreetpit.com/115443-micron-stock-jumps-after-ubs-lifts-price-target/" title="Micron Stock Jumps After UBS Lifts Price Target"><img width="80" height="60" src="https://wallstreetpit.com/wp-content/uploads/2017/02/tech-board4-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="tech board" srcset="https://wallstreetpit.com/wp-content/uploads/2017/02/tech-board4-80x60.jpg 80w, https://wallstreetpit.com/wp-content/uploads/2017/02/tech-board4-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</div>
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/115443-micron-stock-jumps-after-ubs-lifts-price-target/" title="Micron Stock Jumps After UBS Lifts Price Target">
										Micron Stock Jumps After UBS Lifts Price Target									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>February 12, 2020</span>
								</div>
							</header>
						</li>			</ul></div><div id="mh_magazine_custom_posts-2" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://wallstreetpit.com/articles/read-me/" class="mh-widget-title-link">Editor&#8217;s Picks</a></span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/115270-microsoft-dual-screen-foldable-android-smartphone-msft/" title="Microsoft Confirms Making A Dual-Screen Foldable Android Smartphone (MSFT)">
										Microsoft Confirms Making A Dual-Screen Foldable Android Smartphone (MSFT)									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>October 3, 2019</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/115023-elon-musk-tesla-tsla-faced-severe-threat/" title="Elon Musk: &#8216;Tesla (TSLA) Faced a Severe Threat of Death&#8217; Earlier this Year">
										Elon Musk: &#8216;Tesla (TSLA) Faced a Severe Threat of Death&#8217; Earlier this Year									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>November 26, 2018</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/114703-now-thou-dow/" title="How Now, Thou Dow?">
										How Now, Thou Dow?									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>June 23, 2018</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/114444-pentagon-video-suggests-not-alone-universe/" title="Pentagon Video Suggests We May Not Be Alone In The Universe">
										Pentagon Video Suggests We May Not Be Alone In The Universe									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>December 30, 2017</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/113921-bitcoin-debate-future-money-speculative-hype/" title="The Bitcoin Debate: Future of Money or Speculative Hype?">
										The Bitcoin Debate: Future of Money or Speculative Hype?									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>August 6, 2017</span>
								</div>
							</header>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix">
														<header class="mh-custom-posts-header">
								<p class="mh-custom-posts-small-title">
									<a href="https://wallstreetpit.com/113884-tale-two-americas-high-costs-poor-rich-land/" title="A Tale of Two Americas: The High Costs of Being Poor in a Rich Land">
										A Tale of Two Americas: The High Costs of Being Poor in a Rich Land									</a>
								</p>
								<div class="mh-meta mh-custom-posts-meta">
									<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>July 29, 2017</span>
								</div>
							</header>
						</li>			</ul></div><div id="text-11" class="mh-widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SideBarMiddle_300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-9056915385448814"
     data-ad-slot="8652693723"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
		</div>	</aside>	</div>
    </div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
	<div class="mh-footer-mobile-nav"></div>
	<nav class="mh-footer-nav">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-social-icons-menu-container"><ul id="menu-social-icons-menu" class="menu"><li id="menu-item-111048" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111048"><a href="https://www.facebook.com/wallstreetpit" class="external" rel="nofollow" target="_blank">Facebook</a></li>
<li id="menu-item-111049" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111049"><a href="https://twitter.com/wallstreetpit" class="external" rel="nofollow" target="_blank">Twitter</a></li>
<li id="menu-item-111050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111050"><a href="https://plus.google.com/+Wallstreetpit" class="external" rel="nofollow" target="_blank">Google+</a></li>
<li id="menu-item-111051" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-111051"><a href="https://wallstreetpit.com/authors/">Authors</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">Copyright &copy; 2020 <a href="//wallstreetpit.com">Wall Street Pit</a>  |  <a href="mailto:contact@wallstreetpit.com">Contact Us</a>  |  <a href="mailto:sales@wallstreetpit.com">Advertise</a>  |  <a href="//wallstreetpit.com/terms-of-use" rel="nofollow">Terms of Use</a>  |  <a href="//wallstreetpit.com/privacy-policy" rel="nofollow">Privacy Policy</a></p>
	</div>
</div>
<script type='text/javascript' src='https://wallstreetpit.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://wallstreetpit.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://wallstreetpit.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>

<!-- Default Statcounter code for Wall Street Pit
https://wallstreetpit.com -->
<script type="text/javascript">
var sc_project=6494759; 
var sc_invisible=1; 
var sc_security="63ce0558"; 
</script>
<script type="text/javascript"
src="https://www.statcounter.com/counter/counter.js"
async></script>
<noscript><div class="statcounter"><a title="Web Analytics"
href="//statcounter.com/" target="_blank" class="external" rel="nofollow"><img
class="statcounter"
src="//c.statcounter.com/6494759/0/63ce0558/1/" alt="Web
Analytics"></a></div></noscript>
<!-- End of Statcounter Code -->


</body>
</html>